Collaboration

Basic CME Configuration (SIP Only)

Upload Supporting Files

Use the Cisco roadmap to identify the correct version of CME files.

CME
http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/requirements/guide/33matrix.html

SRST
http://www.cisco.com/c/en/us/support/unified-communications/unified-survivable-remote-site-telephony/products-device-support-tables-list.html

Download CME files from Cisco The minimum required with the GUI are;

  1. Phone Loads (Per Device Type SIP or SCCP)
  2. Locale Files
  3. Music On Hold
  4. Ringtones
All files discussed can be either added to the routers flash individually using ftptftp or using 7-Zip  (http://www.7-zip.org/) to create tar file(s) and use the IOS archive tar /xtract … command to upload in bulk into flash.
The phone loads can be downloaded from Cisco (“Downloads Home > Products  > Collaboration Endpoints > IP Phones > XXXX”). Each phone type has a different load and need to be uploaded to the routers flash.
For the locale, moh and ringtones download the appropriate CME tar from Cisco (Downloads Home  > Products > Unified Communications > Call Control > Mid-Market Call Control > Unified Communications Manager Express), the complete file set will contain the tar file for the locales and the individual files for moh and ringtones. You can extract these and upload each to the router flash or add to a tar file with the phone loads and upload in one step with archive tar /xtract.
(test embedded tar files in tar file)

IOS Configuration

Basic


!
ip dhcp excluded-address 192.168.5.1
ip dhcp excluded-address 192.168.5.100 192.168.5.254
!
ip dhcp pool BR3LAN
network 192.168.5.0 255.255.255.0
domain-name home.local
dns-server 192.168.2.250
default-router 192.168.5.1
option 150 ip 192.168.5.1
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.500
encapsulation dot1Q 500
ip address 192.168.5.1 255.255.255.0
!
! All phone load files
tftp-server flash:term45.default.loads
tftp-server flash:term65.default.loads
tftp-server flash:apps45.9-4-2ES26.sbn
tftp-server flash:cnu45.9-4-2ES26.sbn
tftp-server flash:cvm45sip.9-4-2ES26.sbn
tftp-server flash:dsp45.9-4-2ES26.sbn
tftp-server flash:jar45sip.9-4-2ES26.sbn
tftp-server flash:SIP45.9-4-2SR3-1S.loads
!

CME

! CME Basic SIP
!

voice service voip
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/0.500
bind media source-interface GigabitEthernet0/0.500
registrar server
!
voice register global
mode cme
source-address 192.168.5.1 port 5060 !(IP is local CME interface bind)
max-dn 5
max-pool 1
load 7945 SIP45.9-4-2SR3-1S.loads !(for each phone type)
authenticate register
authenticate realm all
tftp-path flash:
create profile sync 0029343150256297
!
voice register dn  1
number 5001005
name simon
!
voice register pool  1
id mac F029.2959.558F
type 7945
number 1 dn 1
username simon password 1234
description SIMON
codec g711ulaw
no vad

!

! CME MTP/XCODE
!
voice-card 0
dspfarm
dsp services dspfarm
!
sccp local GigabitEthernet0/0.500
sccp ccm 192.168.5.1 identifier 1 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/0.500
associate ccm 1 priority 1
associate profile 1 register mtpa0ecf9440b88 !(mtp+bia mac of sccp ccm local interface)
keepalive retries 5
!
dspfarm profile 1 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec g729r8
maximum sessions 2
associate application SCCP
!
telephony-service
sdspfarm units 1
sdspfarm transcode sessions 2
sdspfarm tag 1 mtpa0ecf9440b88   !(mtp+bia mac of sccp ccm local interface)
max-ephones 10
max-dn 10
ip source-address 192.168.5.1 port 2000
!

The “telephony-service” is generally used for CME SCCP configuration as the table below shows the configuration headers for SIP vs. SCCP, but  the MTP (or XCODE) is configured (not mandatory but required if local phones use G.711 and WAN connected CUCM via SIP is throttled to G.729) to allow for XCoding, therefore as the media resources use SCCP to talk to CUCM or CME, the telephony-service configuration is required to enable CME to talk to the media resources (both on the same router). The configuration for telephony-service is the minimum required to have the resources registered, (show sdspfarm units).

Component
SCCP
SIP
IP Phone
ephone
voice register pool
Directory Number
ephone-dn
voice register dn
Telephony Config
telephony-service
voice register global

Additional SCCP Configuration

!
! for 7960 SCCP Phone
tftp-server flash:P0030801SR02.bin
tftp-server flash:P0030801SR02.loads
tftp-server flash:P0030801SR02.sb2
tftp-server flash:P0030801SR02.sbn
!
telephony-service
sdspfarm units 1
sdspfarm transcode sessions 2
sdspfarm tag 1 mtpa0ecf9440b88
!
! addtional commands from previous default SIP setup;
! actually previous only for MTP/XCODE, next 3 same but reqd for SCCP
!
max-ephones 10
max-dn 10
ip source-address 192.168.5.1 port 2000
!
cnf-file location flash:
load 7960-7940 P0030801SR02.loads
! just configure create ‘cnf-files’
create cnf-files version-stamp 7960 Apr 01 2017 10:57:55
! default commands
max-conferences 8 gain -6
transfer-system full-consult
!
! moh for SCCP and SIP phones
moh enable-g711 “flash:music-on-hold.au”
!
!
ephone-dn  1
number 5001006
label 5001006
description Baby Bill
name BB
!
!
ephone  1
device-security-mode none
mac-address 0016.462C.F5DC
username “bb” password 1234
type 7960
button  1:1
!

For SRST;
SCCP – “call-manager-fallback”
SIP – “voice register global”  “mode esrst”

Music On Hold

Music on hold for both SIP and SCCP is configured in “telephony-service”  “moh flash:xx”

Simon Birtles

I have been in the IT sector for over 20 years with a primary focus on solutions around networking architecture & design in Data Center and WAN. I have held two CCIEs (#20221) for over 12 years with many retired certifications with Cisco and Microsoft. I have worked in demanding and critical sectors such as finance, insurance, health care and government providing solutions for architecture, design and problem analysis. I have been coding for as long as I can remember in C/C++ and Python (for most things nowadays). Locations that I work without additional paperwork (incl. post Brexit) are the UK and the EU including Germany, Netherlands, Spain and Belgium.